Top 5 Best Android Apps 2019 - YouTube

Looking for the best Android apps for your mobile phone or tablet? Here are our top 5 must-have apps to install on your Android device. 

Looking for the best Android apps for your mobile phone or tablet? Here are our top 5 must-have apps to install on your Android device. 


My Android app not supporting Android version 9

I have made an android app which uses webView. Everything was fine until I tried my app on Android P. On Android "P" the app is directly showing the error page that the app can't use Internet connection even though it is ON.

I have made an android app which uses webView. Everything was fine until I tried my app on Android P. On Android "P" the app is directly showing the error page that the app can't use Internet connection even though it is ON.

Android Manifest File:

    <?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.xxx.xxxxx.xxxxx">
&lt;!-- android:roundIcon="@mipmap/ic_launcher_round" --&gt;

&lt;uses-permission android:name="android.permission.INTERNET" /&gt;
&lt;uses-permission android:name="android.permission.ACCESS_NOTIFICATION_POLICY"/&gt;
&lt;uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" /&gt;
&lt;uses-permission android:name="android.permission.CAMERA" /&gt;

&lt;application
    android:allowBackup="true"
    android:icon="@drawable/icon"
    android:label="@string/app_name"
    android:hardwareAccelerated="true"
    android:supportsRtl="true"
    android:theme="@style/AppTheme"&gt;
    &lt;activity android:name="com.xxxxx.xxxxx.xxxxxx.MainActivity"&gt;
        &lt;intent-filter&gt;
            &lt;action android:name="android.intent.action.MAIN" /&gt;

            &lt;category android:name="android.intent.category.LAUNCHER" /&gt;
        &lt;/intent-filter&gt;
    &lt;/activity&gt;
&lt;/application&gt;

</manifest>

Gradle File:

    apply plugin: 'com.android.application'

android {
compileSdkVersion 28
defaultConfig {
applicationId "com.xxx.xxx.xxx"
minSdkVersion 19
targetSdkVersion 28
versionCode 3
versionName "3.0"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation 'com.android.support:appcompat-v7:28.0.0'
implementation 'com.android.support.constraint:constraint-layout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
implementation 'com.android.support:design:28.0.0'
}

On Getting error in Android P, directly this section is being accessed:

public void onReceivedError(WebView view, int errorCode,
String description, String failingUrl) {
// You can redirect to your own page instead getting the default error page

            super.onReceivedError(view, errorCode, description, failingUrl);
            String path = Uri.parse("file:///android_asset/error.html").toString();
            webView.loadUrl("about:blank");
            view.loadUrl(path);
        }


Hire Dedicated Android Developers India | Offshore Android Programmer USA

Hire Android app developers with multi-business-domain expertise from award-winning Android mobile, tablet and wearable app Development Company of India and USA to develop an Android app from scratch or work in existing Android application.

Hire Android app developers with multi-business-domain expertise from award-winning Android mobile, tablet and wearable app Development Company of India and USA to develop an Android app from scratch or work in existing Android application.


Running a project in Android Studio - Could not find com.android.tools.build:aapt2:3.3.0-5013011

This is the error message I receive. I downloaded an older project and found solutions to the other error messages. Yet, how can I fix this problem/error message?

Could not find com.android.tools.build:aapt2:3.3.0-5013011.

Searched in the following locations:
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011.pom
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011-windows.jar
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/google/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011.pom
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/google/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011-windows.jar
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/android/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011.pom
  - file:/C:/Users/dimi1/AppData/Local/Android/Sdk/extras/android/m2repository/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011-windows.jar
  - https://jcenter.bintray.com/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011.pom
  - https://jcenter.bintray.com/com/android/tools/build/aapt2/3.3.0-5013011/aapt2-3.3.0-5013011-windows.jar
Required by:
    project :app

This is the error message I receive. I downloaded an older project and found solutions to the other error messages. Yet, how can I fix this problem/error message?